Составьте программу,которая определяет какое из трех введенных с клавиатуры чисел является средним.если среди чисел есть равные,то вывести сообщение"ошибка"
Var a,b,c: integer; begin write('числа: '); readln(a,b,c); if a>b then swap(b,c); if c<a then swap(a,c); if b>c then swap(b,c); if (a=b) or (b=c) then writeln('ошибка') else writeln('среднее: ',b); end.
begin
write('числа: '); readln(a,b,c);
if a>b then swap(b,c);
if c<a then swap(a,c);
if b>c then swap(b,c);
if (a=b) or (b=c) then writeln('ошибка')
else writeln('среднее: ',b);
end.
числа: 9 17 8
среднее: 9