В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
astrafikal
astrafikal
09.01.2021 07:29 •  Информатика

Составьте программу , которая находит произведение чисел в диапазоне от 1 до 10. 1. С командой for to do

2. С командой repeat и until.

Показать ответ
Ответ:
ХПолинаХ
ХПолинаХ
29.09.2020 13:44
Program p452;
var
  a,b,m,d:integer;
begin
  Write('Введите размеры форточки (а,b) в см: ');
  Read(a,b);
  Write('Введите диаметр головы Васи в см: ');
  Read(d);
  if a<b then m:=a+2 else m:=b+2;
  { +2 - это зазор по 1 см с обоих сторон }
  if d<=m then Writeln('Голова проходит')
  else Writeln('Голова не проходит')
end.

Тестовое решение:
Введите размеры форточки (а,b) в см: 25 40
введите диаметр головы Васи в см: 23
Голова проходит

program p453;
var
  a,b,c,x,y,m1,m2,n1,n2:integer;
begin
  Write('Введите размеры кирпича в см (a,b,c): ');
  Read(a,b,c);
  Write('Введите размеры отверстия в см (x,y): ');
  Read(x,y);
  if a<b then
    if a<c then begin
      m1:=a;
      if b<c then m2:=b else m2:=c
    end
    else begin m1:=c; m2:=a end
  else
    if b<c then begin
      m1:=b;
      if a<c then m2:=a else m2:=c
    end
    else begin m1:=c; m2:=b end;
  if x<y then begin n1:=x; n2:=y end
  else begin n1:=y; n2:=x end;
  if (m1<=n1) and (m2<=n2) then Writeln('Кирпич пройдет в отверстие')
  else Writeln('Кирпич не пройдет в отверстие')
end.

Тестовое решение:
Введите размеры кирпича в см (a,b,c): 10 4 12
Введите размеры отверстия в см (x,y): 5 9
Кирпич не пройдет в отверстие

program p454;
var
  a,b:integer;
begin
  Write('Введите значения а и b: '); Read(a,b);
  Writeln('Размеры чемодана ',3*a,'x',2*a,'x',a);
  Writeln('Размеры коробки ',3*b,'x',2*b,'x',b);
  if b<a then Writeln('Коробка поместится в чемодан')
  else Writeln('Коробка не поместится в чемодан')
end.

Тестовое решение:
Введите значения а и b: 18 16
Размеры чемодана 54x36x18
Размеры коробки 48x32x16
Коробка поместится в чемодан
0,0(0 оценок)
Ответ:
marijasoe19gmailcon
marijasoe19gmailcon
25.01.2022 08:20
Const
  nn=50;

type
  data = record
    number : 1..31;
    month : 1..12;
    year : 1901..1997
  end;

var
  d:array[1..nn] of data;
  i,n,k:integer;
  s,s1,s2,s3:string;
begin
  Write('Количество дат (1..50)-> '); Read(n);
  Writeln('Введите через пробел день, месяц, год: ');
  for i:=1 to n do Read(d[i].number,d[i].month,d[i].year);
  { a }
  Write('Самый ранний из годов: ');
  k:=d[1].year;
  for i:=2 to n do
    if d[i].year<k then k:=d[i].year;
  Writeln(k);
  { б }
  Writeln('Все весенние даты');
  for i:=1 to n do
    if d[i].month in [3..5] then
      Write(d[i].number,'.',d[i].month,'.',d[i].year,' ');
  Writeln;
  { в }
  Write('Cамая поздняя дата: ');
  Str(d[1].year,s1); Str(d[1].month,s2); Str(d[1].number,s3);
  if Length(s2)=1 then s2:='0'+s2;
  if Length(s3)=1 then s3:='0'+s3;
  s:=s1+s2+s3;
  for i:=2 to n do
  begin
    Str(d[i].year,s1); Str(d[i].month,s2); Str(d[i].number,s3);
    if Length(s2)=1 then s2:='0'+s2;
    if Length(s3)=1 then s3:='0'+s3;
    if s<s1+s2+s3 then s:=s1+s2+s3
  end;
  Writeln(Copy(s,7,2)+'.'+Copy(s,5,2)+'.'+Copy(s,1,4))
end.

Тестовое решение:
Количество дат (1..50)-> 6
Введите через пробел день, месяц, год:
18 4 1950
16 5 1968
5 8 1970
3 9 1968
11 6 1964
16 12 1967
Самый ранний из годов: 1950
Все весенние даты
18.4.1950 16.5.1968
Cамая поздняя дата: 05.08.1970
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота