В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составьте программу которая копирует из строки "наступила холодная зима " слово "зима"

Показать ответ
Ответ:
iprin
iprin
13.08.2021 19:57
Const   n = 5; var   i: integer;   a: array[1..n * 2 + 1] of integer; begin   writeln('исходный массив: ');   for i : = 1 to 2 * n do   begin       a[i] : = random(99) + 1;       write(a[i] : 5);   end;   for i : = 2 * n + 1 downto n + 1 do       a[i] : = a[i - 1];   a[n + 1] : = 0;   writeln();   writeln('полученный массив: ');   for i : = 1 to 2 * n + 1 do       write(a[i] : 5); end.
0,0(0 оценок)
Ответ:
marina18190
marina18190
25.05.2021 10:15

С давних пор люди сталкивались с необходимостью определять расстояния, длины предметов, время, площади, объемы и т. д.

Измерения нужны были и в строительстве, и в торговле, и в астрономии, фактически в любой сфере жизни. Очень большая точность измерений нужна была при строительстве египетских пирамид.

Рис. 0

Значение измерений возрастало по мере развития общества и, в частности, по мере развития науки. А чтобы измерять, необходимо было придумать единицы различных физических величин. Вспомним, как написано в учебнике: “Измерить какую-нибудь величину – это значит сравнить ее с однородной величиной, принятой за единицу этой величины”.

Целью моей работы было выяснить: какие существовали и существуют сейчас единицы длины и массы, каково их происхождение?

Вершок, локоть и другие единицы...

Измеряй все доступное измерению и делай не доступное измерению доступным”.

Г.Галилей

Самыми древними единицами были субъективные единицы. Так, например, моряки измеряли путь трубками, т. е. расстоянием, которое проходит судно за время, пока моряк выкурит трубку. В Испании похожей единицей была сигара, в Японии – лошадиный башмак, т. е. путь, который проходила лошадь, пока не износится привязанная к ее копытам соломенная подошва, заменявшая подкову.

В программе Олимпийских игр Древней Эллады был бег на стадию. Установлено, что греческая стадия (или стадий) это длина стадиона в Олимпии – 192,27 м. Стадий равняется расстоянию, которое проходит человек спокойным шагом за время от появления первого луча солнца, при его восходе, до момента, когда диск солнца целиком окажется над горизонтом. Это время приблизительно равно двум минутам ...

Стадий, как единица измерения расстояний, был и у римлян (185 см), и у вавилонян (около 195 см), и у египтян (195 см).

В Сибири в стародавние времена употреблялась мера расстояний – бука. Это расстояние, на котором человек перестает видеть раздельно рога быка.

У многих народов для определения расстояния использовалась единица длины стрела – дальность полета стрелы. Наши выражения “не подпускать на ружейный выстрел”, позднее “на пушечный выстрел” – напоминают о подобных единицах длины.

Древние римляне расстояния измеряли шагами или двойными шагами (шаг левой ногой, шаг правой). Тысяча двойных шагов составляла милю (лат. “милле” – тысяча).

Длину веревки или ткани неудобно измерять шагами или стадиями. Для этого оказались пригодными встречающиеся у многих народов единицы, отождествляемые с названиями частей человеческого тела. Локоть – расстояние от конца пальцев до локтевого сустава.

     

Рис. 1                                  Рис. 2

Мерой длины для тканей, веревок и т.п. наматывающихся материалов у многих народов был двойной локоть. Этой мерой мы и сейчас пользуемся для приблизительной оценки длины...

На Руси долгое время в качестве единицы длины использовали аршин (примерно 71 см). Эта мера возникла при торговле с восточными странами (перс, “арш” – локоть). Многочисленные выражения: “Словно аршин проглотил”, “Мерить на свой аршин” и другие – свидетельствуют о ее распространении.

Для измерения меньших длин применяли пядь – расстояние между концами расставленных большого и указательного пальцев.

Рис. 3

Пядь или, как ее еще называли, четверть (18 см) составляла 1 / 4 аршина, а 1/ 16 аршина равнялся вершок (4,4 см).

Очень распространенной единицей длины была сажень. Впервые упоминание о ней встречается в XI в. С 1554 г. сажень устанавливают равной 3 аршинам (2,13 м) и она получает название царской (или орленой, печатной) в отличие от произвольных – маховой и косой. Маховая сажень – размах рук – равна примерно 2,5 аршинам. Рыбак, который показывает, какую большую рыбу он упустил, демонстрирует нам маховую.

Рис. 4

Косая сажень – расстояние от конца вытянутой вверх правой руки до носка левой ноги, она примерно равна 3,25 аршинам.

Рис. 5

Вспомним, как в сказках о великанах: “Косая сажень в плечах”. Удивительно совпадение древнеримской меры длины - "архитектур

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота