В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kotik53Tv
kotik53Tv
30.07.2020 20:14 •  Информатика

Составьте программу, которая генерирует случайное четы- рехзначное число от 1000 до 9999 (номер автобусного билета), выводит
его на экран и определяет, является ли билет «счастливым» (сумма
первых двух цифр равна

сумме последних двух цифр).​

Показать ответ
Ответ:
tanya596
tanya596
07.09.2020 23:01

Var i,C,B:integer;A:Array[1..5]of integer;

Begin

 C:=1;B:=9;

 for i:=1 to 4 do

   A[i]:=random(b-c+1)+c;      

   Write('Билет-');

   For i:=1 to 4 do

    Write(A[i]);

   If A[1]+A[2]=A[3]+A[4] then Begin Writeln; writeln('Билет счастливый')end else Begin Writeln; writeln('Билет не счастливый');end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота