В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
MaliaCr
MaliaCr
13.04.2023 04:31 •  Информатика

Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0; 7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3,а к нечётное умножает на 4

Показать ответ
Ответ:
anavidyan920
anavidyan920
26.05.2020 17:25

Program Program1;
var
i:integer;
a:array [1..10] of integer;
begin
randomize;
writeln;
writeln('Массив до преобразования:');
for i:=1 to 10 do
begin
a[i]:=random(8);
write(a[i],', ');
end;
for i:=1 to 10 do
if a[i] mod 2 = 0 then
a[i]:=a[i]+3
else
a[i]:=a[i]*4;
writeln;
writeln('Массив после преобразования:');
for i:=1 to 10 do
write(a[i],', ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота