В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
megakolbina
megakolbina
04.03.2020 09:54 •  Информатика

Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от - 20 до 20 и четные числа делит на два, а нечетные - умножаем на три ,

Показать ответ
Ответ:
kmay11
kmay11
04.10.2020 13:20
Vari:integer;a:array [1..15] of integer;
begin
for i:=1 to 15 do begin
a[i]:=Random(-20,20);
end;
write('Исходный массив ');
for i:=1 to 15 do begin
write(a[i]);write(' ');
end;
for i:=1 to 15 do begin
if (a[i] mod 2 = 0) then
a[i]:=a[i] div 2
else
a[i]*=2;
end;
writeln();
write('Преобразованный массив ');
for i:=1 to 15 do begin
write(a[i]);
write(' ');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота