В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Лолик1112
Лолик1112
09.10.2022 01:55 •  Информатика

Составьте программу, которая формирует массив из 20 случайных чисел от -10 до 10выводит на экрын элементы с нулевыми значениями и их индексами

Показать ответ
Ответ:
макашария
макашария
07.10.2020 10:49
Const Sz = 100; // Размер массива

var
a: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i: integer;

begin
N := 20;
for i:=1 to N do
a[i] := Random(20)-10;
writeln('Элементы массива: ');
for i:=1 to N do
write (a[i],' ');
writeln;
for i:=1 to N do
begin
if (a[i]=0) then
writeln(a[i],' ',i);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота