В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
evstropovi1632
evstropovi1632
18.03.2020 14:35 •  Информатика

Составьте программу, используя подпрограмму (процедуру или функцию). в одномерном массиве случайных чисел mas [1..15] вычислить произведение элементов, кратных 3.это все нужно в паскале.

Показать ответ
Ответ:
Федот2003
Федот2003
11.08.2020 14:53

var mas:array [1..15] of integer;


i:integer;


k:biginteger;


function f(mas:integer):boolean;


begin


if (mas mod 3=0) then f:=True;


if (mas mod 3<>0) then f:=False;


end;


BEGIN


k:=1;


for i:=1 to 15 do begin


mas[i]:=random(100)+1;


write(mas[i],' ');


if (f(mas[i])=True) then k:=k*mas[i];


end;


writeln();


if (k=1) then writeln('Нет элементов, кратных 3') else


writeln(k);


end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота