В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
пепоам
пепоам
21.02.2021 17:23 •  Информатика

Составьте программу для вычисления суммы ряда .s=2/3 *n + 2/3 * n^2 + 2/3 *n^n. с функцией или процедурой

Показать ответ
Ответ:
Прлплмопо
Прлплмопо
02.10.2020 21:47
Program test;
function s(n,a:integer) : real;
var i,p:integer;
begin
  p:=1;
  if n>1 then begin
    for i:=1 to n do p:=p*a;
    s:=p;
  end;

end;
function sum(n:integer) : real;
var i:integer;
sum1:real;
begin
  for i:=1 to n do begin
    sum1:=sum1+(2/3)*s(i,n);
  end;
  sum:=sum1;
end;
var
  n:integer;
begin
  write('Введите количество чисел ');
  readln(n);
  writeln(sum(n));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота