Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
сырнаябулочка21
02.05.2022 16:34 •
Информатика
Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа.
Показать ответ
Ответ:
Arina0903
10.07.2020 14:21
Program z1;
var
a: integer;
c: byte;
begin
readln(a);
c:=0;
while a <> 0 do begin
c:=c + a mod 10;
a:=a div 10;
end;
writeln('Summa: ', c);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Adventurous
20.03.2021 00:21
Удавы и кролики (простейший расчет)модель «хищник - жертва» (по в.вольтера) имеет вид: где g - численность «жертв» (кроликов); н- численность «хищников» (удавов); dq – приращение...
Аккаунт удален
11.09.2022 05:50
Составьте программу на языке паскаль для вычисления суммы: z=5+9+13+17++x, где x 5.! ...
calusiker
03.10.2021 06:37
Дан массив из 5 цифр подсчитать сумму элементов используя procedure для чтения и function для решения a[-3; 100; 10; 12; 18]...
alinodhakota
03.10.2021 06:37
Скорость чтения учащегося составляет приблизительно 250 символов в минуту. приняв мощность используемого алфавита за 64 ,определите, какой объём информации в килобайтах получит учащийся,...
podgornovakatu
29.11.2020 11:38
В таблице представлены несколько записей из базы данных «Расписание»: № Учитель День недели Номер урока Класс 1 Айвазян Г.С. понедельник 3 8А 2 Айвазян Г.С. понедельник 4 9Б 3 Айвазян...
daramalahova907
21.08.2022 00:34
Задача.На тіло діє сила тяжіння 500 Н. якою є маса його тіла...
Яяяячканр345
20.09.2021 12:21
Помагите англис ком #7Match a sentence beginning in A with a preposition in B and an ending in C....
alenushkabelya
17.11.2021 05:19
Hi Danny! How are you? I went to the 1) last weekend with my 2) . I saw a great 3) called Macbeth. It s by William Shakespeare and this very 4) . The 5) we re fantastic! The plot...
vo10
22.01.2021 01:27
мальчик массой 45 кг стоит на лыжах. Длина каждой лыжи 1,5 м, ширина 10 см. Какое давление оказывает мальчик, стоящий без лыж. Площадь подошв его ботинок равна 250 см²...
emmavalse
04.11.2021 21:12
Выберите все правильные варианты ответов Особенности развития Казахстана в период «перестройки»: 1)Освоение целины2)Попытка создания немецкой автономии на территории Казахстана3)Забастовка...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
a: integer;
c: byte;
begin
readln(a);
c:=0;
while a <> 0 do begin
c:=c + a mod 10;
a:=a div 10;
end;
writeln('Summa: ', c);
end.