В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
werdam
werdam
04.04.2021 15:01 •  Информатика

Составьте программу для вычисления стоимости покупки: Дано:
Цена сахара-x руб
Кол-во сахара -3 кг
Цена муки-у руб
Кол-во муки-5 кг
Цена риса-z руб
Кол-во риса- 1 кг
Найти St-стоимость покупки.

Показать ответ
Ответ:
FREDDY2017
FREDDY2017
09.02.2023 19:22
  var mas:array[0..9] of integer; 
 i,max,min,k:integer;
  arifm:real;
begin 
k:=0;
arifm:=0; 
 Randomize;
  for i:=0 to 9 do
  mas[i]:=Random(15);
  for i:=0 to 9 do 
 write(mas[i],'  '); 
 {poisk max} 
   max:=mas[0];
     for i:=1 to 9 do 
    if max<mas[i] then 
    max:=mas[i]; 
     {poisk min} 
   min:=mas[0]; 
   for i:=1 to 9 do 
    if min>mas[i] then 
    min:=mas[i];
     arifm:=(max+min)/2; 
    writeln('max: ',max); 
   writeln('min: ',min); 
    writeln('arifm: ',arifm:0:3); 
   for i:=0 to 9 do 
   if mas[i]<arifm then 
    inc(k); 
   writeln('k: ',k);
  readln;
end.
0,0(0 оценок)
Ответ:
Dashahaahaa
Dashahaahaa
24.08.2020 00:24
Нашел 2 ошибки в 4- строке и 7- строке, объясняю на примере а=15, b=26
как я понял по данным задачи К больше или равно А то есть начальное значение S = A, вторую ошибку можно решить просто поменяв местами операторы 7-ой и 8-ой строки(чтобы сначала программа суммировала S=15+15 а потом уже 30+16,46+18...пока S<B а в задаче делается так 16+1,16+17, 30+18,...) в общем:
var a, b, s, k: integer;begin
read(a,b);
s := a;<
k := a;
while s < b do begins := s+k;<k := k+1;<end;writeln(k)end. 

если
a=15 b=36
ответ будет :15
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота