Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Рикания
01.09.2021 21:06 •
Информатика
Составьте программу для вычисления периметра и площади прямоугольника, если известны координаты противоположных вершин прямоугольника (x1,x2) и (y1,y2). стороны прямоугольника параллельны осям координат.
Показать ответ
Ответ:
привет897
03.07.2020 17:15
Program qq;
uses crt;
var
x1,x2,y1,y2,a,b,S,P:integer;
Begin
Readln(x1,y1,x2,y2);
a:=x2-x1;
b:=y2-y1;
S:=a*b;
P:=(a+b)*2;
Writeln(S,P);
Readkey;
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
олеся786
30.03.2021 01:34
1)Сколько обменов будет совершено при пузырьковой сортировке массива из 4 элементов, равных -3, 7, -9, 4?...
slovendim
13.02.2021 05:17
Вам дается число n, которое состоит из цифр 9 и 6. Вам нужно выбрать ровно одну цифру и перевернуть ее (если перевернут 9, то получится 6 и наоборот). Например, если n равно 96996...
mjh60661
10.09.2021 00:02
7. sntp для того чтобы компьютеры поддерживали актуальное время, они могут обращаться к серверам точного времени sntp (simple network time protocol). к сожалению, компьютер не может...
homya4okm
25.01.2021 05:01
Выберите строки, в которых условные операторы на языкеPascal записаны без ошибок.if 10 then k:= k+1;if (x mod y=0) then else writeln( no)if x 0 then y:= 100 div x; еlѕе y= 0;if x...
вероника20048
24.09.2020 22:19
Охарактеризуйте исполнителя чертёжник 6кл с127...
ДарьяДуда
30.08.2020 01:13
Put the words into the correct order to make questions 1./ you/what/are/doing? 2./cooking/are/you/what/? 3./tonight/where/you/going/are? 4./playing/we//tennis/what time/are? 5./crying/girl/why/is/this?...
k1llerospace
30.08.2020 01:13
Из посёлка на станцию пешеход шёл со скоростью 5 км/ч, а возвращался со скоростью на 1 км/ч меньшей, затратив на обратный путь на 24 минуты больше. на каком расстоянии от поселка...
za2ba2wa2
30.08.2020 01:13
Где живёт утконос? знаю там где тепло,но где?...
Picmout
30.08.2020 01:13
Какой вариант в пропущенное вставить in her album now ? a) does she draw b)does she drawing c) she drawing d) is she drawing my colleagues to our boss with great interest. a) are...
DENCHIK23371
30.08.2020 01:13
:read the sentences. are thearticles in bold used correctly? underline and correct the mistakes. 1. the red square is situated in the centre of the moscow. 2. the uk consists of...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
uses crt;
var
x1,x2,y1,y2,a,b,S,P:integer;
Begin
Readln(x1,y1,x2,y2);
a:=x2-x1;
b:=y2-y1;
S:=a*b;
P:=(a+b)*2;
Writeln(S,P);
Readkey;
End.