В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
swetakorchagov
swetakorchagov
06.07.2021 15:07 •  Информатика

Составьте программу для вычисления функции, заданной графиком, применяя вложенное или каскадное ветвление


Составьте программу для вычисления функции, заданной графиком, применяя вложенное или каскадное ветв

Показать ответ
Ответ:
Dimafdj
Dimafdj
05.09.2022 06:28
На языке Java. Программа складывает и отрицательные и положительные числа.

class SumNum{
 public static void main(String args[]){
  try{
   long sumNum=0,numSum=new Long(new java.io.BufferedReader(new java.io.InputStreamReader(System.in)).readLine());
   do sumNum+=numSum;while((numSum>0?--numSum:++numSum)!=0);System.out.print("Результат "+sumNum);
  }catch(java.io.IOException io){
   System.out.println(" - Ошибка ввода!\n"); main(null);
  }catch(NumberFormatException nf){
   System.out.println(" - Введите целочисленное значение!\n"); main(null);
  }
 }
}
0,0(0 оценок)
Ответ:
hammyhjh
hammyhjh
18.03.2023 20:51

program Project1;

const

 maxelem = 100;

var

 a: array [1..maxelem] of integer; { Переменная для  хранения массива.}

 n: integer; {  Переменная для хранения значения количества элементов в массиве.}

 i,k: integer; { Вс переменные для организации циклов.}

 sum: integer; {  Переменная для хранения значения суммы выбранных величин роста}

begin

 n:= 15;

 for i:= 1 to n do

   repeat

     write('Введите значение ',i,' элемента: ');

     Readln(a[i]);

     if (a[i] < 150) or (a[i] > 200) then

       writeln('Введенное число не входит в заданный диапазон.');

   until (a[i] >= 150) and (a[i] <= 200);

 writeln('Исходный массив: ');

 for i:= 1 to n do

   begin

     write(a[i]:5);

     if i mod 10 = 0 then

       writeln;

   end;

 sum:= 0;

 k:= 0;

 for i:= 1 to n do

   if a[i] > 180 then

     begin

       sum:= sum + a[i];

       inc(k);

     end;

 writeln;

 if k = 0 then

   writeln('В классе нет учеников с ростом выше 180 см.')

 else

   writeln('Средний рост игроков баскетбольной команды: ',(sum/k):0:2);

 Readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота