В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
елена430
елена430
08.05.2020 02:14 •  Информатика

Составьте программу для ввода с клавиатуры в массив 10 целых чисел и вывода первых 5-и чисел в обратном порядке в первую строку, во вторую строку – последние четыре числа в обычном порядке, а в третьей строке – первый и девятый элементы массива (

Показать ответ
Ответ:
ilinovam
ilinovam
04.10.2020 00:55
Var b:integer;
    a: array [0..9] of integer;
    
begin
randomize;
for b:=0 to 9 do begin
  read(a[b]);
end;

for b:=4 downto 0 do begin
  write(a[b],' ');
end;
writeln('');

for b:=6 to 9 do begin
  write(a[b],' ');
end;
writeln('');

for b:=0 to 9 do begin
 if ((b=0)or (b=8)) then write(a[b],' ');
end;
writeln('');

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота