В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
KarenXacul80
KarenXacul80
28.11.2020 03:28 •  Информатика

составьте программу для решения задачи (на ПК) . Для пошива полотенец рулон ткани длиной D м нарезают по M см. Сколько отрезов получится ? Какой будет длинна остатка ?​

Показать ответ
Ответ:
Winxsori
Winxsori
01.02.2020 03:41
Const     
n = 10; 
var   
a : array [1..n] of integer; 
r : boolean;   
i,j : integer;
 begin 
//Формирование массива пропущено   
 
r := true;      
While r do   
begin   
 if a[i] mod 2 =0 then     
begin     
 for j := n-1 downto i + 2 do       
 a[j] := a[j-1];       
a[i+1] := 0;       
r := false;     
end;     
i := i +1;   
end;  
for i := 1 to n do 
writeln (a[i]);   
end.

Во избежании ошибок стоит учесть наличие такового элемента в массиве и размерность массива (чтобы его можно было корректно расширить на один элемент)
0,0(0 оценок)
Ответ:
ltandreeva2016
ltandreeva2016
17.02.2023 03:34
Procedure Dec2Oct(n:longint);
{ Перевод натурального десятичного n в восьмеричную систему счисления
  и вывод результата }
const
  alpha = '01234567';
var
  s: string;
  i:integer;
begin
  s := '';
  while n > 0 do begin
    s := alpha[(n mod 8) + 1] + s;
    n := n div 8
  end;
  for i:=Length(s) to 9 do s:='0'+s;
  Write(s)
end;

{ Использование }
var
  x:longint;
begin
  Write('Введите десятичное число: '); Read(x);
  Write('В восьмеричной системе счисления: ');
  Dec2Oct(x);
  Writeln
end.

Тестовое решение:
Введите десятичное число: 1234567
В восьмеричной системе счисления: 0004553207
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота