В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ванесса07
Ванесса07
26.12.2020 03:00 •  Информатика

Составьте программу для решения следующей : дан массив из 20 элементов, заполненныей случайными числами . найти минимальный элемент массива и его номера

Показать ответ
Ответ:
Twister04
Twister04
03.08.2020 14:50
#include <iostream>

using namespace std;

int main()
{
    setlocale(LC_ALL, "RUSSIAN");
    const int arr_len=20;
    int arr[arr_len];
    int i = 0;
    srand(8120);
    for (i = 0; i < arr_len; i++)
    {
        arr[i] = rand() % 100;
        cout << arr[i] << ' ';
    }
    cout << endl;
    int min = 100, min_index=arr[0];
    for (i = 0; i < arr_len; i++)
    {
        if (arr[i] < min)
        {
            min = arr[i];
            min_index = i;
        }
    }
    cout << "Минимальный элемент массива: " << min << endl;
    cout << "Его индекс: " << min_index << endl;
    system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота