В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ruslanmorozko
ruslanmorozko
19.12.2020 06:43 •  Информатика

Составьте программу для решения двух квадратных уравнений используя процедуру решения квадратного уравнения​

Показать ответ
Ответ:
SEMKA22444
SEMKA22444
28.05.2020 17:03

Var a,b,c,d,x1,x2: real;

Begin

Clrscr;

Write('введите коэффициенты уравнения a,b,c'); readln(a,b,c);

D:=b*b-4*a*c;

If d>=0 then

Begin

X1:=(-b+sqrt(d))/(2*a); x2:=(-b-sqrt(d))/(2*a);

Writeln('x1=',x1' x2=',x2)

END;

Else writeln('действительных корней нет')

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота