В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nikita5000011111
nikita5000011111
21.05.2023 19:19 •  Информатика

Составьте программу для получения частного q и остатка r при делении числа x на число y ​

Показать ответ
Ответ:
yuljasha1982p0bvky
yuljasha1982p0bvky
16.06.2020 20:26

for (ip = mas; ip < mas+len; ip ++) if (*ip < *min)   min = ip

после  завершения поиска - перестановка  : *ip = *min;   *min =*mas; *mas = *ip

\\  main вроде как объявит матрицу, и выполнит управление вызовами функций- void и main(void)

{  n, m;  matr [N][M]; i;input_matr (matr, n, m)

int

int  \\ Матрица будет объявлена размером 5 на 5   int

\\потом она передастся в функцию ввода.

\\ Для преобразования матрицы ее строки передаются в функцию по очереди как  одномерные массивы. Цикл управления находится в основной программе.

\\и он управляет передачей строк в функцию.

for (i = 0;i < n;i ++)

Change (matr[i], m); \\ matr[i], это i – тая строка матрицы.

\\Функция вывода матрицы вызывается после завершения обработки.

print_matr (matr, n, m); }

\\ End of main

0,0(0 оценок)
Ответ:
AnnYtAa1
AnnYtAa1
10.02.2022 11:05

program test1;

var r, minim, i: integer;

a: array[1..12] of integer;

begin

 for i:=1 to 12 do

 begin

   a[i]:= random(100);

 end;

 minim := a[1];

 for i:=1 to 12 do

 begin

   if minim > a[i] then

     minim:= a[i];

 end;

 writeln('минимальное значение=', minim);

end.

program test2;

var i: integer;

var poisk: string;

a: array[1..20] of integer;

begin

 for i:=1 to 20 do

 begin

   a[i]:= random(100);

 end;

 for i:=1 to 20 do

 begin

   if a[i] = 65 then

     poisk:=poisk + i;

 end;

 if poisk = '' then

   writeln('нет элементов массива со значением 65')

 else writeln('элемент(ы) массива со значением 65 ',poisk)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота