В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Elyanoname
Elyanoname
04.09.2022 13:26 •  Информатика

Составьте программу для паскаль сегодня утром жюри решило добавить в вариант олимпиады еще одну, легкую . ответственный секретарь оргкомитета напечатал ее условие в одном экземпляре, и теперь ему нужно до начала олимпиады успеть сделать еще n копий. в его распоряжении имеются два ксерокса, один из которых копирует лист за х секунд, а другой – за y. (разрешается использовать как один ксерокс, так и оба одновременно. можно копировать не только с оригинала, но и с копии.) ему выяснить, какое минимальное время для этого потребуется. входные данные на вход программы поступают три натуральных числа n, x и y, разделенные пробелом (1 ≤ n ≤ 2∙108, 1 ≤ x, y ≤ 10). выходные данные выведите одно число – минимальное время в секундах, необходимое для получения n копий. метрополитен состоит из нескольких линий метро. все станции метро в городе пронумерованы натуральными числами от 1 до n. на каждой линии расположено несколько станций. если одна и та же станция расположена сразу на нескольких линиях, то она является станцией пересадки и на этой станции можно пересесть с любой линии, которая через нее проходит, на любую другую (опять же проходящую через нее). напишите программу, которая по данному вам описанию метрополитена определит, с каким минимальным числом пересадок можно добраться со станции a на станцию b. если данный метрополитен не соединяет все линии в одну систему, то может так получиться, что со станции a на станцию b добраться невозможно, в этом случае ваша программа должна это определить. входные данные сначала вводится число n — количество станций метро в городе (2≤n≤100). далее следует число m — количество линий метро (1≤m≤20). далее идет описание m линий. описание каждой линии состоит из числа pi — количество станций на этой линии (2≤pi≤50) и pi чисел, номера станций, через которые проходит линия (ни через какую станцию линия не проходит дважды). затем вводятся два различных числа: a — номер начальной станции, и b — номер станции, на которую нам нужно попасть. при этом если через станцию a проходит несколько линий, то мы можем спуститься на любую из них. так же если через станцию b проходит несколько линий, то нам не важно, по какой линии мы приедем. выходные данные выведите минимальное количество пересадок, которое нам понадобится. если добраться со станции a на станцию b невозможно, программа должна вывести одно число –1 (минус один).

Показать ответ
Ответ:
Molka2005
Molka2005
07.10.2020 16:14
1)
Program kpa6ya;var x,y,N:integer;BEGINwriteln('x=');readln(x);writeln('y=');readln(y);writeln('N=');readln(N);if (N<1) and (N<2*108) then  begin    writeln('BBeguTe oT 1 go 2*108 4ucJlo N, a He ',N);    readln(N);  end;writeln(N/(x+y),' - BpeM9');END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота