В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
szhanibekov
szhanibekov
25.11.2021 01:20 •  Информатика

Составьте программу для pascal abc, решающую следующую . у продавца имеются гири весом 1, 2, 5 кг. наберите минимальное кол-во гирь для взвешивания n кг.

Показать ответ
Ответ:
Dasha292001
Dasha292001
06.07.2020 22:38
Program z1;
        var n:integer;
        s1,s2,s5:integer;
begin
        write('n=');readln(n);
        s5:=n div 5;n:=n mod 5;
        s2:=n div 2;s1:=n mod 2;
        writeln('5 kg-',s5,';   2 kg-',s2,';   1 kg-',s1);
        readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота