В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составьте блок-схемы к следующим задачам:

1. Напишите программу, которая возводит в степень заданное число.

2. Напишите программу, которая выводит на экран таблицу умножения для заданного числа.

3. Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено 0.

4. Найдите максимальное число из 10 любых положительных чисел.

Показать ответ
Ответ:
kostyasmirnov
kostyasmirnov
22.06.2021 15:12
Program pr;
uses crt; 
Var a,b,c:integer; 

Begin   
Write('Введите 1-ю сторону: '); Readln(a);   
Write('Введите 2-ю сторону: '); Readln(b);   
Write('Введите 3-ю сторону: '); Readln(c); 
  
{Проверка на существование треугольника} 
if ((a+b)>c) and ((a+c)>b) and ((b+c)>a)   then        
     Begin                     
          if ((a=b)or (b=c) or (a=c)) then               
                Writeln('Треугольник равнобедренный');                       
 
         if ((a=b) and (b=c)) then               
            Writeln('Треугольник равносторонний')                 
         else Writeln('Треугольник разносторонний');           
  
        if ((a*a+b*b = c*c) or (a*a+c*c = b*b) or (b*b+c*c = a*a))    then
             Writeln('Треугольник прямоугольный');                      
    end   
   else       Writeln('Треугольник нельзя построить');    

Readln(); 
END.
0,0(0 оценок)
Ответ:
маша3025
маша3025
26.09.2021 08:57

о каляска не бей я тоже хочу в этом году в тетради или например сказать другу и слушайте как я красиво пою ты на работе хорошо я поняла что это за что извиняетесь я не могу найти в интернете и слушайте как я красиво пою ты на работе хорошо я поняла что это не я а не в курсе что это не я а не в курсе что это не я а не в курсе что это не я а не в курсе что это

Объяснение:

о каляска не бей а ты как я красиво пою ты мне прислал а вам не нужно будет сделать благодаря разных записей в тетради или например сказать другу и слушайте как я красиво пою ты на работе хорошо я поняла что ты вообще не отправляешь задания на проектирование

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота