В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
badery346
badery346
14.03.2022 11:20 •  Информатика

Составьте БЛОК СХЕМУ Составьте программу нахождения среднего арифметического значения

одномерного массива А(N) (элементы массива вводятся с клавиатуры).

Сформируйте новый массив В(М), состоящий из элементов массива А(N),

больших среднего арифметического.

Показать ответ
Ответ:
ангелина867
ангелина867
13.06.2022 00:27

array = [3, 6, -2, 7, -5, -6, 8, 16, 64, 23, -45, 24, 15, 3, 5]

sum1 = 0

dob = 1

index1 = 0

index2 = 0

index3 = 0

sum2 = 0

for i in range(len(array)):

   if array[i] < 13:

       sum1 = sum1 + array[i]

   if array[i] > 0:

       dob = dob * array[i]

       index1 = index1 + 1

       sum2 = sum2 + (array[i] * array[i])

   if array[i] < 0:

       index2 = index2 + 1

   if array[i] % 2 != 0:

       index3 = index3 + 1

print("Сума елементів масиву, які менші за 13: " + str(sum1))

print("Добуток додатніх елементів масиву: " + str(dob))

print("Кількість додатніх елементів масиву: " + str(index1))

print("Кількість від\'ємних елементів масиву: " + str(index2))

print("Кількість непарних елементів масиву: " + str(index3))

print("Квадрат суми непарних елементів масиву: " + str(sum2))

0,0(0 оценок)
Ответ:
Sharjnik
Sharjnik
28.08.2020 04:09

IP-адрес (aй-пи адрес, сокращение от англ. Internet Protocol Address) — уникальный идентификатор (адрес) устройства (обычно компьютера) , подключённого к локальной сети или интернету.

IP-адрес состоит из двух частей: номера сети и номера узла. В случае изолированной сети её адрес может быть выбран администратором из специально зарезервированных для таких сетей блоков адресов (192.168.0.0/16, 172.16.0.0/12 или 10.0.0.0/8). Если же сеть должна работать как составная часть Интернета, то адрес сети выдаётся провайдером либо pегиональным интернет-регистратором (Regional Internet Registry, RIR).

IP-адрес представляет собой 32-битовое (по версии IPv4) или 128-битовое (по версии IPv6) двоичное число. Удобной формой записи IP-адреса (IPv4) является запись в виде четырёх десятичных чисел (от 0 до 255), разделённых точками, например, 192.168.0.1. (или 128.10.2.30 — традиционная десятичная форма представления адреса, а 10000000 00001010 00000010 00011110 — двоичная форма представления этого же адреса).

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота