В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Nastia2047
Nastia2047
21.05.2022 06:38 •  Информатика

Составьте блок-схему и напишите программу на языке программирования Паскаль:

1)Одноклеточная амёба каждые три часа делится на 2 клетки. Составьте алгоритм вычисления времени, через которое будет Х амёб.
Используйте оператор repeat.

2)Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён ноль) и определение максимального (наибольшего) из введённых чисел.Используйте оператор

Показать ответ
Ответ:
nuk890
nuk890
19.11.2022 08:38

ответ:Доброго времени суток.

Очень не корректно поставлен вопрос. Что есть Текст? Это текстовый файл, строка, введенная пользователем, еще что-то? Думайте, прежде чем спросить, и, скорее всего, получите нормальный ответ.

Поэтому, поскольку нет конкретики, будем считать текстом строку, введенную пользователем.

Write('Введите текст : ');

ReadLn(S);

В переменной S теперь находится некоторый текст. Начнем с ним работать. Будем считать словом последовательность символов, ограниченных с обеих сторон пробелами. Сначала сделаем копию введенного текста.

S1 := ' ' + S + ' '; {чтобы не потерять первое и последнее слова}

А дальше,  

N := 0; {счетчик слов Мама}

while Pos(' Мама ', S1) > 0 then begin

Delete(S1, Pos(' Мама ', S1)+1, 4);

N := N + 1;  

end;

Поскольку может в тексте быть и "мама", то повторим

while Pos(' мама ', S1) > 0 then begin

Delete(S1, Pos(' мама ', S1)+1, 4);

N := N + 1;  

end;

Вот и все. Осталось вывести результат.

WriteLn('Во ввденном тексте слово "мама" встречается ', N, ' раз');

Удачи!

PS Можно было бы не делать второй проход, если предварительно преобразовать введенный текст к одному регистру, а затем искать подстроку в этом регисте.

0,0(0 оценок)
Ответ:
andreyrekvinov
andreyrekvinov
01.06.2020 14:58
№ 1 Используя логические операции, запишите высказывания, которые являются истинными при выполнении следующих условий: 1) неверно, что 0 < X ≤ 3 и Y>5; 2) X является max(X,Y); 3) X не является min(X,Y); 4) Z является min(X,Y,Z). № 2 Используя логические операции, запишите высказывания, которые являются истинными при выполнении следующих условий: 1) Y не является max(X,Y,Z) и не является min(X,Y,Z); 2) X,Y,Z равны между собой; 3) каждое из чисел X,Y,Z положительно; 4) каждое из чисел X,Y,Z отрицательно.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота