В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
SpaceRZX
SpaceRZX
21.03.2022 18:30 •  Информатика

составить программузаполнить матрицу(двумерный массив) из 16 элементов (4Х4) случайными числами от -5 до 11

Показать ответ
Ответ:
bogdanostapenko
bogdanostapenko
02.02.2020 07:40
Var
    a: array [,] of integer;

begin
    var n := ReadlnInteger('n = ');
    var m := ReadlnInteger('m = ');
    var rand := ReadlnInteger('Для ручного ввода нажмите 0');
    
    if rand = 0 then begin
        a := new integer[m, n];
        for var i := 0 to m-1 do
            for var j := 0 to n-1 do
                a[i, j] := ReadlnInteger('a[' + i + ',' + j + '] = ');
    end
    else a := MatrixRandom(m, n, 1, 100);
    Println(a);
    
    var b := ArrGen(n, x -> 1);
    for var i := 0 to m-1 do
        for var j := 0 to n-1 do
            if j mod 2 = 0 then
                b[j] := b[j] * a[i, j];
    
    b.Where((x, i)-> i mod 2 = 0).SortedDescending().Println();
end.
0,0(0 оценок)
Ответ:
KimTaeHyung3012
KimTaeHyung3012
06.09.2022 13:23

#include <iostream>

using namespace std;

//Так будет проще читать числа с консоли

int Input(string text)

{

   cout << text;

   int result;

   cin >> result;

   return result;

}

int main ()

{

   int x = Input("Input X: ");

   

   //Задача А

   cout << "A: " << endl;

   int nums1[10];

   for (int i = 0; i < 10; i++)

       nums1[i] = x;

       

   //Задача Б

   cout << "B: " << endl;

   int nums2[10];

   for (int i = 0; i < 10; i++)

       nums2[i] = x + i;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота