В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу вывода 30 целых чисел на экран
Блок-Схему, без паскаля

Показать ответ
Ответ:
lizalubavina
lizalubavina
23.05.2021 01:14

Бірлік кесіндісі 1 см болатын координаталық түзуде А(-1) және В(5)

нүктелерін белгілеңдер. А және В нүктелерінің арақашықтығын табыңдар;

ә) А нүктесінен 2 см қашықтықта орналасқан А1 және А2 , ал В нүктесінен

3 см қашықтықта орналасқан В1 және В2 нүктелерін координаталық

жазықтықта белгілеңдер. Олардың координаталарын жазыңдар. [4]

2. х айнымалысының орнына қойғанда |х| < 2,3 теңсіздігі ақиқат болатындай

барлық бүтін сандарды жазыңдар. [2]

3. -2

3

7

+ 54

7

+ |−2

6

7

| + (-2,5) өрнегінің мәнін есептеңдер. [4 ]

4. Шеңбердің диаметрі 180 см болса, онда шеңбердің ұзындығы мен

дөңгелектің ауданы неге тең? [3]

А) 282,6 см, 25 434 см2

; В) 565,2 см, 25 434 см2

;

С) 565,6 см, 25 436 см2

; Д) 565,6 см, 25 446 см2

,

5. Егер 1: 50 000 000 масштабы бар картада 5 см жергілікті жерде қанша

километрді береді?

А) 2050 км; В) 2400 км; С) 2500 км; Д) 25 500км.

0,0(0 оценок)
Ответ:
petrgulyaev06
petrgulyaev06
23.11.2022 10:27
Код Pascal1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 const n=100; type arr=array[1..n] of integer; var   a:arr;   skv:real;   i,k,l:integer; procedure print(s:string;a:arr;l:integer); var   i:integer; begin   writeln(s);   write('[');   for i:=1 to l-1 do write(a[i],', ');   writeln(a[l],']'); end; procedure sort(var a:arr;l:integer); var   i,j,t:integer; begin   for i:=1 to l-1 do     for j:=i to l do       if a[j]<a[i] then begin         t:=a[j];         a[j]:=a[i];         a[i]:=t;       end; end; begin   repeat     write('Количество элементов массива:');     readln(k);   until (k>0) and (k<101);   write('Введите массив:');   for i:=1 to k do     repeat       write('a[',i,']=');       readln(a[i]);     until (a[i]>-11) and (a[i]<11);   print('Оригинальный массив:',a,k);   l:=0;skv:=0.0;   for i:=1 to k do     if a[i]<0 then begin       a[i]:=sqr(a[i]);       skv:=skv+a[i];       l:=l+1;     end else a[i]:=i;   print('Полученный массив:',a,k);   sort(a,k);   print('отсортированный массив:',a,k);   writeln('Среднее арифметическое квадратов отрицательных чисел:',skv/l:0:4);   readln; end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота