В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
GalaxyTuna
GalaxyTuna
24.02.2021 00:29 •  Информатика

Составить программу, вычисляющую площадь фигуры. тип фигуры определяется символом (с): о – окружность, t – равнобедренный прямоугольный треугольник и k – квадрат. целое число, вводимое вслед за символом определяет соответствующий элемент для вычисления площади (для окружности это радиус, для треугольника – длина катета, для квадрата – длина стороны).

Показать ответ
Ответ:
Гектор31
Гектор31
21.09.2020 13:00
Var
S, X, a, b, R: Real;
C: String;
Begin
WriteLn('Chto budem vichislat');
ReadLn(C);
if C = 'O' then begin
WriteLn('Radius');
ReadLn(R);
S:= Pi*sqr(R);
end;
if C:= 'T' then begin
WriteLn('Vvedite 1 katet);
ReadLn(a);
WriteLn('Vvedite 2 katet);
ReadLn(b);
S:= 1/2 * a * b;
end;
if C:= 'K' then begin
WriteLn('Vvedite 1 katet);
ReadLn(a);
S:= sqr(a);
end;
WriteLn('Ploshad = ');
ReadLn(S);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота