Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Лубничка
14.07.2022 08:37 •
Информатика
Составить программу вычисляющую периметр ромба, если известны его диагонали.(pascal)
Показать ответ
Ответ:
AllRay1
13.07.2020 22:10
Program qq;
var p,d1,d2:real;
begin
write('Введите значение 1 диагонали');
readln(d1);
write('Введите значение 2 диагонали');
readln(d2);
p:=4*sqrt((sqr(d1)/2)+(sqr(d2)/2));
write('Периметр ромба=',p);
end.
Вроде так, но может быть ошибка
0,0
(0 оценок)
Популярные вопросы: Информатика
Норман11
12.09.2021 07:24
Подсчитать количество информации в тексте из 800 символов, мощность алфавита – 128 символов....
milankae
12.09.2021 07:24
Вводится последовательность из n произвольных чисел. найти наибольшее число в последовательности. если таких чисел несколько, определить, сколько их. программирование...
valerija1234
02.09.2022 15:46
Уасхата есть жесткий диск объемом 4 гб. сколько книг может хранить асхат на этом диске?...
Karneg
02.09.2022 15:46
Примеры когда одна модель может соответствовать нескольким объектам...
Miras19932708
08.03.2020 03:46
Даны натуральные числа m, n. получить все кратные им числа, меньшие m*n. сделать на паскале )...
2156kolllokir
07.01.2021 17:51
Скорость передачи данных через adsl-соединение равна 1024000 бит/с. через данное соединение файл размером 2000 кбайт. определите время передачи файла в секундах....
zalikmap08ic7
01.05.2021 07:16
Определить сколько слов в тексте содержит не более 3 букв. (в паскаль) вроде на , пож-! надо...
vipzemleduh
01.02.2023 01:16
Дан массив вещественных чисел,содержащий 25 элементов вычислить сумму элементов массива начиная с первого элемента и максимального элемента массива включительно...
snezoc
01.02.2023 01:16
Чем пищеварительная система планарии отличается от пищеварительной системы дождевого червя...
Хажижа
01.02.2023 01:16
Найдите значение производной функции f(x) = (8/x2) – √x в точке x0 = 4....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var p,d1,d2:real;
begin
write('Введите значение 1 диагонали');
readln(d1);
write('Введите значение 2 диагонали');
readln(d2);
p:=4*sqrt((sqr(d1)/2)+(sqr(d2)/2));
write('Периметр ромба=',p);
end.
Вроде так, но может быть ошибка