В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
onkyyyyyyy
onkyyyyyyy
18.07.2020 19:26 •  Информатика

Составить программу вычисления значений функции y = f (x) на промежутке a, b с шагом h (на языке C++): cos(x)/x^2+7sin^2(x)-5
a=1 b=4 h=0,15

Показать ответ
Ответ:
умник162д
умник162д
30.12.2021 10:10

#include <iostream>

#include <cmath>

using namespace std;

long double f(double x) {

return cos(x) / pow(x, 2) + 7 * pow(sin(x), 2) - 5;

}

int main() {

double a, b, h;

cin >> a >> b >> h;

for (double i = a; i <= b; i += h)

 cout << "f(" << i << ") = " << f(i) << '\n';

}


Составить программу вычисления значений функции y = f (x) на промежутке a, b с шагом h (на языке C++
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота