В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ElenaAristova1501
ElenaAristova1501
05.05.2021 22:28 •  Информатика

Составить программу вычисления в одномерном массиве с произведения четных и положительных элементов и сумму элементов меньших 6

Показать ответ
Ответ:
nfyrb2014
nfyrb2014
24.07.2020 20:32
Var
  c:array [1..10] of integer;
  i, even, positive, sumLessSix: integer;
begin
  randomize;
  writeln ('Рандомный массив');
  for i:=1 to 10 do begin
    c[i]:= random(20)-10;
    write (c[i],' ');
  end; {for}
  writeln;
  writeln('Произведение четных чисел');
  even:=1;
  for i:=1 to 10 do
    if c[i] mod 2 = 0  then
    even:= even*c[i];
  write(even,' ');
  writeln;
  writeln('Произведение положительных чисел');
  positive:=1;
  for i:=1 to 10 do
    if c[i] > 0 then
    positive:= positive*c[i];
  write(positive,' ');
    writeln;
  writeln('Сумма элементов меньших 6');
  positive:=1;
  for i:=1 to 10 do
    if c[i] < 6 then
    sumLessSix:= sumLessSix+c[i];
  write(sumLessSix,' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота