В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
hophip2
hophip2
22.01.2020 03:01 •  Информатика

Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b ( от1 до 100). нужно составить 1- с циклом с пред условием, 2 - с циклом с пост условием

Показать ответ
Ответ:
Elvira2018
Elvira2018
19.06.2020 09:12
1)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
for a:=1 to 99 do begin
if a mod b = 0 then
sum:=sum+a;
end;
writeln(sum);
end.

2)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
repeat 
if a mod b = 0 then
sum:=sum+a;
inc(a);
until a=100
writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота