В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
petrovspb
petrovspb
01.09.2022 07:19 •  Информатика

Составить программу вычисления суммы мест, на которых в строке, введенной с клавиатуры, стоят согласные буквы. например в 'строке' сумма мест согласных букв равняется 1+2+3+5+=11

Показать ответ
Ответ:
ololsha99
ololsha99
02.10.2020 16:55
Var 
s,g:string;
sum:integer;
begin
g:='';
read(s);
sum:=0;
for var i:=1 to length(s) do
if (pos(s[i],g)>0) then sum:= sum+i; 
writeln(sum);
end.
//ABC Pascal
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота