В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
145milana
145milana
26.07.2022 20:02 •  Информатика

Составить программу вычисления суммы и произведения натуральных чисел кратных 9

Показать ответ
Ответ:
0p3n
0p3n
11.06.2020 23:17

Вот.

 

Program z1;
Uses crt;
Const N=15;
Var a:array [1..n] of integer;
sum,i,pr:integer;
Begin
sum:=0;
For i:=1 to n do
begin
a[i]:=random(10)-15;

Writeln(a[i]);
end;
for i:=1 to n do
if a[i] mod 9 = 0 then
begin
sum:=sum+a[i];
pr:=1*a[i];
end;

Writeln('Сумма:');
Writeln(sum);

Writeln('Произведение:');
write(pr);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота