В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
IceOneBro
IceOneBro
06.04.2020 16:46 •  Информатика

Составить программу вычисления среднего арифметического первых 50 чисел много

Показать ответ
Ответ:
виктория1447
виктория1447
08.10.2020 01:01

program HelloWorld;

var sum : double;

var i : integer;

 

begin

       

    //sum := (50*(50+1)/2)/50;

    for i:=1 to 50 do

      sum:= sum + i;

    sum:= sum/50;

   

    writeln('Средне-арифметическое от 1 до 50 равно:');

    writeln(sum:15:2);

  

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота