В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
irina20042005
irina20042005
08.06.2022 15:50 •  Информатика

Составить программу вычисления площади треугольника по основанию и высоте.
pascal

Показать ответ
Ответ:
foximmortal
foximmortal
10.02.2023 12:45
Program Loto;
Uses Crt;
Const lt = 49; (* количество шаров в лототроне *)
shar = 6; (* количество выигрышных шаров*)
Var lott,vyb : array [1..shar] of integer;
i, j, nom, k : integer;
m:set of byte;
Begin
randomize;
m:=[];
for i:=1 to shar do
begin
repeat
nom:=1+random(lt);
until not(nom in m);
lott[i]:=nom;
m:=m+[nom];
end;
writeln('Выберите шаров от 1 до 6 ',lt);
m:=[];
begin
repeat
write('nom',i,'=');
readln(nom);
until (nom in [1..lt])and not(nom in m);
vyb[i]:=nom;
m:=m+[nom];
end;
clrscr;
writeln('Номера шаров в лототроне');
for i:=1 to shar do write(lott[i]:3);
writeln;
writeln('Выбранные шары');
for i:=1 to shar do
write(vyb[i]:3);
writeln;
write('Совпавшие шары: ');
k:=0;
for i:=1 to shar do
for j:=1 to shar do
if lott[i]=vyb[j] then
begin
k:=k+1;
write(lott[i]:3);
end;
if k=0 then write('- нет')
else write('  Их количество=',k)
end.
0,0(0 оценок)
Ответ:
Александра894312
Александра894312
10.02.2020 00:00
Первое задание ->

#include <stdio.h>
int main(){
int N,O,K; // N - delimoe (vvodim s klaviaturq), O - ostatok ot delenija, K - chastnoe ot delenija   

int i=1; //delitelj   
int j=0; //kolichestvo delitelej
    printf("Vvedite naturaljnoe chislo - ");   
    scanf("%d", &N);
    do{       
          K=N/i;       
          O=N%i;       
           i++;       
           if(O==0){           
                    //printf("\n%d", K); //vqvodim chisla           
                     j++;       
              }   
         }while(K!=0);
         printf("\n\nKolichestvo delitelej: %d\n", j);
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота