В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
LuKи
LuKи
18.10.2020 13:14 •  Информатика

Составить программу вычисления функции на языке PASCAL(номер 1 и 3)


Составить программу вычисления функции на языке PASCAL(номер 1 и 3)

Показать ответ
Ответ:
kalmykov24
kalmykov24
23.06.2020 00:47

1.

program prog;  

var  

  x,y:real;  

begin  

 writeln('x=?');  

 readln(x);  

 if x<=-4 then  

   y:=x*x*x-2;  

 if 6<=x then  

   y:=40-x;  

 if (-4<x) and (x<6) then  

   y:=x*x;  

 writeln('y ',y:1:3)  

end.

3.

program prog;  

var  

  x,y:real;  

begin  

 writeln('x=?');  

 readln(x);  

 if x<1 then  

   y:=2*x-17;  

 if (1<=x) and (x<=5) then  

   y:=exp(ln(x)*7);  

 if 5<x then  

   y:=x*ln(x);  

 writeln('y ',y:1:3)  

end.

exp(ln(x)*n)

,где n - степень , x - выражение.

(используется во втором упражнение которое я решил, согласитесь лучше будет выглядеть чём х*х*х*х*х*х*х)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота