В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ymnusha
Ymnusha
21.10.2021 10:05 •  Информатика

составить программу вычислений множество значений функций. (на pascal abc )


составить программу вычислений множество значений функций. (на pascal abc )

Показать ответ
Ответ:
Violettik2006
Violettik2006
09.06.2021 23:47
На каком языке програмирования?
на Java
public class MyClass {
public static void main(String[] args) throws Exception{
BufferedReader reader = new BufferedReader(new InputStreamReader(System.in)));
System.out.println("введите координаты");
System.out.println("x:");
Integer x = Integer.valueOf(reader.println());
System.out.println("y:");
Integer y = Integer.valueOf(reader.println());
Заштрихованая область как определяется?
пусть она уже задана и имеет вид прямоугольника.
int lefiXofSpace = 5;
int rightXofSpace = 10;
int upYof Space = 7;
int downYof Space = 5;
if((x >= leftXofSpace && x <= rightXofSpace) && (y >= downYofSpace && y <= upYofSpace)) {
System.out.printl("Точка попала в заштрихованую область");
} else {
System.out.printl("Точка не попала в заштрихованую область");
}
}
}
0,0(0 оценок)
Ответ:
Kseiaa
Kseiaa
05.04.2023 23:41
1. Не дано из какой системы счисления. Если из 10 в 10, то будет 483
2. Не дано из какой системы счисления. Если из 10 в 2, то будет
483 = 2^8 * 1 + 2^7 * 1 + 2^6 * 1 + 2^5 * 1 + 2^4 * 0 + 2^3 * 0 + 2^2 * 0 + 2^1 * 1 + 2^0 * 1 = 111 100 011
3. Не дано из какой системы счисления. Если из 10 в 8, то будет 
483 = 8^2 * 7 + 8^1 * 4 + 8^0 * 3 = 743
4. Как знаем, что 483 в двоичной будет 111 100 011, то в восьмеричную будет 743 (делишь число на три части. 7 это 111, 4 это 100, а 3 это 011)
5. Знаем, что 483 в десятичной будет 483, то в шестнадцатеричной будет 1Е3. (не знаю как сделать, но будет так)
6. ответ такой же как выше. Число 111100011 делим на части по 4 символа. Получаем 0001 1110 0011 (добавляем впереди нули), и по таблице будет 1Е3
7. Нельзя перевести, так как в восьмеричной системе счиления цифры только 0 1 2 3 4 5 6 7. А вот из шестнадцатеричной можно в восьмеричную число 483. Будет 2203. 

И сама таблица, если ее нет
0) 0000
1) 0001
2) 0010
3) 0011
4) 0100
5) 0101
6) 0110
7) 0111
8) 1000
9) 1001
А) 1010
B) 1011
C) 1100
D) 1101
E) 1110
F) 1111
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота