В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Rossen
Rossen
29.03.2021 03:18 •  Информатика

Составить программу вычисление площади треугольника по трём сторонам. s=1\2aha

Показать ответ
Ответ:
Люсик20
Люсик20
16.07.2020 11:45
По трем сторонам - формула Герона.
var a,b,c,p:real;
begin
write('Введите стороны: ');
readln(a,b,c);
p := (a + b + c) / 2;
writeln('Площадь равна ', sqrt(p * (p - a) * (p - b) * (p - c)):9:4);
end.

А через основание и высоту (твоя формула):
var a,h:real;
begin
write('Введите длину основания и высоты, проведенной к нему: ');
readln(a, h);
writeln('Площадь равна: ', (a * h) / 2:9:4);

:9:4 -- это такой оператор, который выводит число в формате с фиксированной точкой и 4 знаками после запятой.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота