В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу в С++builder, заменяющую во введенном строковом выражении указанную подстроку нужным числовым значением в строковом представлении. tg(x), где х - число.

Показать ответ
Ответ:
tiomashash
tiomashash
27.11.2021 11:53

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

Объяснение:

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

0,0(0 оценок)
Ответ:
viktrozumovskaoyqqjq
viktrozumovskaoyqqjq
26.12.2020 19:30
1. Наука, изучающая законы и формы мышления, называется:
Г) логика
 
2. Повествовательное предложение, в котором что-то утверждается или отрицается называется:
В) высказывание
 
3. Константа, которая обозначается «1» в алгебре логики называется: 
В) истина
 
4. Какое из следующих высказываний являются истинным? 
В) II + VI = VIII (2 + 6 = 8, записанное при римских чисел)
 
5. Объединение двух высказываний в одно с союза «и» называется: 
Б) конъюнкция
 
6. Чему равно значение логического выражения (1v1)^(1v0)? 
А) 1 ((1 v 1) ^ (1 v 0) = 1 ^ 1 = 1)
 
7. Что такое логика?
B) это наука о формах и законах человеческого мышления и, в частности, о законах доказательных рассуждений
 
8. Логической операцией не является:
A) логическое деление
 
9. Объединение двух высказываний в одно с оборота «если..., то..» называется:
Г) импликация
 
10. Таблица, содержащая все возможные значения логического выражения, называется:
Б) таблица истинности
 
11. Даны три высказывания: 
А = (Наступила осень)
В = (Мы учимся в колледже)
С = (Мы решаем контрольную работу)
Напишите в виде формулы высказывание: «Наступила осень, мы учимся в колледже и решаем контрольную работу» 
ABC
 
12. Придумайте ложное высказывание, соответствующее функции и постройте таблицу истинности для следующей функции:
Х=А+ВС
В ответе выписать комбинации А, В, С при которых Х – ложно.
Например, если A = (Скопье – столица Черногории), B = (Скопье – столица Македонии) и C = (Скопье – столица Эфиопии), то X = A + BC соответствует ложному высказыванию "Скопье – столица Черногории или Македонии и Эфиопии".
Таблица истинности:
A B C X
0 0 0 0
0 0 1 0
0 1 0 0 – случай из примера
0 1 1 1
1 0 0 1
1 0 1 1
1 1 0 1
1 1 1 1
X ложно при (A, B, C) = (0, 0, 0), (0, 0, 1), (0, 1, 0).
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота