В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Janiya1404
Janiya1404
17.10.2022 01:14 •  Информатика

составить программу в Python . Дан номер месяца целое число в диапазоне 1-12 (1 январь ,2 февраль и т.д) Напишите программу Которая выводит название соответствующего времени года (Зима , Весна ,Лето ,Осень)

Показать ответ
Ответ:
mashatemni
mashatemni
25.02.2021 13:59

a = int(input())

b = ['Январь', 'Февраль', 'Март', 'Апрель', 'Май', 'Июнь', 'Июль', 'Август', 'Сентябрь', 'Октябрь', 'Ноябрь', 'Декабрь']

def mt():

   print('Месяц:', b[a - 1])

def vb(a):

   print(f'Время года: {a}')

if a in [12, 1, 2]:

   vb('Зима'); mt()

elif a in [3, 4, 5]:

   vb('Весна'); mt()

elif a in [6, 7, 8]:

   vb('Лето'); mt()

elif a in [9, 10, 11]:

   vb('Осень'); mt()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота