Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Janeke
07.10.2020 22:45 •
Информатика
Составить программу в паскале. заменить в тексте слово "sin" на слово "cos" и подсчитать количество замен.
Показать ответ
Ответ:
NINO11111
26.07.2020 18:54
Var y,x: string;
i,k: integer;
begin
k=0;
read (x);
for i:=1 to length(x) do
begin
y:=copy(x, i,3);
If (y='sin') then begin
delete (x, i, 3);
insert ('cos', x, i);
k:=k+1;
end;
writeln (x);
writeln (k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
nikonova1977
18.10.2022 08:07
Решите контрошку.подалуйста...
kinderlolo19999
24.06.2021 18:23
Запишите число в десятичной системе счисления числа а5=34,1, а3=221, а7=120, а16=е41а,12. !...
romankostin2006
20.11.2020 13:17
Іть відгадати ребус про (сонце намальоване) 40...
suchilinaelya
19.01.2021 17:12
Написать эссе на тему: возможна ли наша речь без фразеологизмов.эссе на страницу. заранее...
lnv76911
20.07.2021 21:58
Эссе подъем городской культуры ( казахстана)...
Андрей22111111
20.07.2021 21:58
Повесть недоросль. какие действия стародума доказывают что он положительный герой? ? нужно....
123456uiop
20.07.2021 21:58
Рассчитайте массу медной детали, объём которой 0,00002м³...
jimitapark
20.07.2021 21:58
С! найдите площадь прямоугольника,если его периметр равен 40см.,а отношение сторон равно 2: 3....
rus170
20.07.2021 21:58
1) в каком слове все согласные звуки глухие стряпуха, чайка, яша, сходка 2) в каком ряду оба слова можно перенести яшма,портрет плакат,здесь мгла,редька вскользь,окно 3)...
maxim1213
20.07.2021 21:58
Написати текст и виписати 10 словосполучень...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i,k: integer;
begin
k=0;
read (x);
for i:=1 to length(x) do
begin
y:=copy(x, i,3);
If (y='sin') then begin
delete (x, i, 3);
insert ('cos', x, i);
k:=k+1;
end;
writeln (x);
writeln (k);
end.