В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
grenzygaming
grenzygaming
01.10.2022 12:54 •  Информатика

Составить программу в паскале: из n введенных чисел найти максимальное значение среди положительных элементов.

Показать ответ
Ответ:
Yaroslav1RUS
Yaroslav1RUS
09.07.2020 13:29
Текст программы в документе.
0,0(0 оценок)
Ответ:
незнаю177
незнаю177
09.07.2020 13:29
Program abc;
type 
   mas = array[0..1000] of integer;
var 
   a: mas;
   i, n, max: integer;
begin
  WriteLn('Введите кол-во эл-тов массива:');
  ReadLn(n);
  for i := 1 to n do
  begin
    WriteLn('Введите значение элемента №', i);
    ReadLn(a[i]);
  end;
  WriteLn('Все элементы массива имеют значение');
  max := -1;
  for i := 1 to n do
    if a[i] > max then
      max := a[i];
    if max <> -1 then
      Writeln('Максимальное значение положительного элемент = ', max)
    else Writeln('Положительных элементов нет');
    ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота