В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kostya79bat1
kostya79bat1
13.11.2020 02:22 •  Информатика

Составить программу в паскале ! двум приятелям родители подарили по новому мотоциклу .подростки поспорили кто быстрее пройдет обкатку двигателя 2500 км. первый проехал километры за 12 дней, а второй в первый день проехал 150 км, а в каждый следующий он прибавлял 20 км. нужно разрешить их спор и выявить кто сделал обкатку быстрее

Показать ответ
Ответ:
оксаночка25
оксаночка25
08.07.2020 15:24
Const
  s = 2500; {пробег для обкатки}
  n1 = 12;{число дней, потраченное первым подростком}

var
  s0, s2: real;
  n2: integer;

begin
  s0 := 150;
  n2 := 1;
  s2 := s0;
  while s2 < s do
  begin
    s0 := s0 + 20; {ежедневный пробег}
    s2 := s2 + s0;
    n2 := n2 + 1
  end;
  if n2 > n1 then Writeln('2-й подросток завершил обкатку позже на ', n2 - n1, ' дн.') 
  else if n2 = n1 then Writeln('Оба подростка завершили обкатку одновременно')
  else Writeln('2-й подросток завершил обкатку раньше на ', n1 - n2, ' дн.')
end.

Решение:
2-й подросток завершил обкатку раньше на 1 дн.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота