В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Diana15007
Diana15007
13.01.2020 03:26 •  Информатика

Составить программу в паскале для поиска простых чисел в числовом промежутке от 1 до 100

Показать ответ
Ответ:
taklecovatana
taklecovatana
12.06.2020 10:18

program abc;
var
  i, j:integer;
  pr:boolean;
begin
  writeln('Простые числа в диапазоне от 1 до 100: ');
  for i := 2 to 100 do
  begin
    pr := true;
    for j := 2 to i div 2 do
      if i mod j = 0 then
      begin
        pr := false;
        break;
      end;
    if pr then
      write(i, ' ');
  end;
  writeln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота