В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу в Паскале для обработки массива из 10 чисел Х = (–17,3; 13,2; –7; –2,36; 123,4; –0,3; 12,356; 142; 0; –1). Вычислить количество элементов массива с нечетными номерами на отрезке [5,1..32,4]. В отчет включить программный код и результат работы программы.

Показать ответ
Ответ:
Абзал111111
Абзал111111
12.10.2020 08:05

var A: array[1..10] of real =  

(-17.3, 13.2, -7, -2.36, 123.4, -0.3, 12.356, 142, 0, -1);

var i,cnt: integer;

begin

cnt:=0;

for i:=1 to 10 do

 begin

 if ((A[i]>=5.1) and (A[i]<=32.4) and (i mod 2 <> 0))

 then cnt:=cnt+1;

 end;

writeln('Количество элементов массива с нечетными номерами',

'на отрезке [5,1..32,4]: ', cnt);

end.


Составить программу в Паскале для обработки массива из 10 чисел Х = (–17,3; 13,2; –7; –2,36; 123,4;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота