В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kakaxa6
kakaxa6
29.04.2022 19:31 •  Информатика

Составить программу в паскале.даны три положительных числа а,в,с. проверить, могут ли быть они длинами сторон треугольник. если да, то вычислить площадь треугольника. (нужно учитывать, что стороны не могут равняться нулю. и возможно существование равностороннего треугольника) основные формулы: а< =б+с, б

Показать ответ
Ответ:
artmani228
artmani228
12.06.2020 06:31

var a,b,c,p:integer;
begin
  writeln('введите a');
   readln(a);
  writeln('введите b');
   readln(b);
  writeln('введите c');
   readln(c);
  if (a<=b+c) and (b<a+c) and (c<=a+b) then
    begin
       p:=(a+b+c) div 2;
       writeln('Треугольник может существовать');
       writeln('Площадь: ', sqrt(p* ((p-a)*(p-b))*((p-c))):1:2);  //Формула герона
    end
  else writeln('Не треугольник');
  readln();
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота