В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
romantik17lol
romantik17lol
22.08.2020 09:30 •  Информатика

Составить программу в паскале! дано четырехзначное число заменить в нем наибольшую цифру нулем.

Показать ответ
Ответ:
saaaasss01
saaaasss01
01.10.2020 12:18
Var n,d,a,h,o,max:integer;
begin
readln(n);
d:=n div 1000;
h:=(n mod 1000) div 100;
a:= n mod 100 div 10 ;
o:=n mod 10; 
If (d>h) and (d>a) and  (d>o) then max:=d;
If (h>d) and (h>a) and  (h>o) then max:=h;
If (a>d) and (h<a) and  (a>o) then max:=a;
If (o>d) and (h<o) and  (a<o) then max:=o;
If d=max then writeln(0,h,a,o);
If h=max then writeln(d,0,a,o);
If a=max then writeln(d,h,0,o);
If o=max then writeln(d,h,a,0);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота