В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
89539123898
89539123898
29.02.2020 22:57 •  Информатика

Составить программу в Паскаль.

На соревнованиях по прыжкам в длину участвовало 10 спортсменов. Результаты прыжков занесены в массив В [10]. Определите три лучших результата (выведете их на экран).

Показать ответ
Ответ:
БУЛИЧКА23
БУЛИЧКА23
06.12.2020 14:03

program jumping;

var

 i, j, temp: integer;

 B: array [1..10] of integer;

begin

 for i := 1 to 10 do  

   read(B[i]);  

 for i := 1 to 9 do

   for j := 1 to 10 - i do

     if (B[j] < B[j + 1]) then

     begin

       temp := B[j];

       B[j] := B[j + 1];

       B[j + 1] := temp;

     end;

 writeln('Первое место: ', B[1]);

 writeln('Второе место: ', B[2]);

 writeln('Третье место: ', B[3]);

end.

Объяснение:

program jumping;  // Название программы

var

 i, j, temp: integer;  // Целочисленные переменные:

i - переменная счетчик для цикла forj - переменная счетчик для цикла fortemp - переменная для временного хранения значений массива

 B: array [1..10] of integer;  // Целочисленный массив из 10 чисел

begin  // Начало программы

 for i := 1 to 10 do // Идём с первого по десятый элементы массива

   read(B[i]); // Ввод значений массива

// Сортировка массива в порядке убывания

 for i := 1 to 9 do  // Идём с первого по девятый элементы массива

   for j := 1 to 10 - i do  // Идём с первого по 10 - i элементы массива

     if (B[j] < B[j + 1]) then  // Если последующий элемент больше предыдущего

     begin  // Начало цикла

       temp := B[j];  // Временная переменная = значению массива B с индексом j

       B[j] := B[j + 1];  // Значение массива B с индексом j = значению массива B с индексом j + 1

       B[j + 1] := temp;  // Значение массива B с индексом j = значению временной переменной

     end;  // Конец цикла

 writeln('Первое место: ', B[1]);  // Вывод ответа

 writeln('Второе место: ', B[2]);  // Вывод ответа

 writeln('Третье место: ', B[3]);  // Вывод ответа

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота