В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ychenik2525
Ychenik2525
02.08.2021 00:17 •  Информатика

Составить программу (в pascal) позволяющую найти минимальный элемент массива. подсчитать количество элементов в массиве, равных минимальному. размеренность массива произвольная.

Показать ответ
Ответ:
кактус107
кактус107
26.06.2020 11:00
Program my;
var  k,i,z:integer; 
     a:array[1...N]:integer; 
begin
k:=99999;
for i:=1 to N do                   
 if a[i]<k then k:=a[i];
z:=0;
for i:=1 to N do 
 if a[i]=k then z:=z+1;
end.
=)  
0,0(0 оценок)
Ответ:
Taya200401
Taya200401
26.06.2020 11:00
Uses crt;
const N=10;
var a:array [1..N] of integer;
     x,min,k:integer;
begin
for x:=1 to N do
begin
write('a[',x,']:',a[x]);
readln(a[x]);
end;
min:=a[1];
for x:=1 to N do
if a[x]<min then min:=a[x];
for x:=1 to N do
if a[x]=min then inc(k);
writeln('Минимальный элемент: ',min,'. Таких элементов в массиве: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота