В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DЕNA
DЕNA
02.10.2022 12:10 •  Информатика

Составить программу в pascal для нахождения корней квадратного уравнения ax^2+bx+c=0

Показать ответ
Ответ:
noname0002
noname0002
01.10.2020 13:27
Uses crt;
var
    d, a, b, c, x1, x2: real;

begin
    writeln('Введите a, b, c');
    readln(a, b, c);
    d := b * b - 4 * a * c;
    
    if d > 0 then
    begin
        x1 := (-b + sqrt(d)) / (2 * a);
        x2 := (-b - sqrt(d)) / (2 * a);
        writeln('x1 = ', x1:2:2);
        writeln('x2 = ', x2:2:2);
    end
    else if d = 0 then
    begin
        x1 := -b / (2 * a);
        writeln('x = ', x1:2:2);
    end
    else
        writeln('Нет действительных корней');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота