В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nikrozumenko
nikrozumenko
21.09.2022 13:32 •  Информатика

Составить программу в pascal. 1. в последовательности чисел подсчитать произведение чисел, кратных 3.

Показать ответ
Ответ:
MrFoksSuper
MrFoksSuper
16.07.2020 01:15
Var x, sum: integer;
begin
  sum := 1;
  writeln('Введите последовтельность чисел.', #10, '0 - остановить программу, получить результат.');
  repeat
    readln(x);
    if(x mod 3 = 0)  and (x <> 0) then sum := sum * x;
  until(x = 0);
writeln('Произведение числе кратных 3: ', sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота